
What Is QUALCOMM’s PureVoice?

Now you can share your baby’s gurgling sounds with loved ones thousands of miles away, via e-mail. You
can send a voice greeting or message to a friend or business associate halfway around the world, over 
the Internet. In fact, you can share your voice with anyone in the world who has an e-mail account, 
access to the Internet, and a computer running Windows or Macintosh.*

Slow typists have been waiting a long time for the ability to record and send voice messages over e-mail. 
And if you want to send a message in a language other than the one you can type on your computer, 
QUALCOMM’s PureVoice offers a fast and easy solution.

QUALCOMM’s PureVoice™ Player-Recorder lets you record and send voice messages with your e-mail, 
and lets your recipients play back your voice-mail messages on their Windows or Macintosh computer 
with the click of a mouse.*

PureVoice runs on your Windows, Macintosh, or Solaris machine and features an easy-to-use onscreen 
VCR-like instrument panel.

Voice messages you compose with PureVoice have extremely high sound quality — very nearly as high 
as you would experience in a local phone call made over a good-quality home telephone. Yet the voice 
messages take up very little space on your computer, and travel very fast over e-mail. You send a voice 
message by attaching it to an e-mail message using your existing e-mail software — in most cases, this is
achieved at the touch of a button in PureVoice! You can also include text in the e-mail message, and 
attach other files such as graphics and documents. QUALCOMM’s PureVoice is compatible with most e-
mail systems, including QUALCOMM’s own Eudora Pro and Eudora Light.

The average computer user comfortably speaks at a rate 10 times faster than he or she can type. There 
is no need to spell-check a voice message. Voice mail avoids the misinterpretation of moods common in 
typed e-mail: with voice messages, your recipients don’t have to guess when you’re being wry, funny, or 
serious. And on the pocketbook side, you can send voice messages without incurring any additional long-
distance telephone charges!

In an age in which computers are thought to keep us apart, QUALCOMM’s PureVoice Player-Recorder 
brings us closer together, adding a human touch to communication.

* In order for you to record a voice message using QUALCOMM’s PureVoice, you must be using a PC 
running a 32-bit version of the Windows operating system (Windows 95, 98 or Windows NT), or you 
must be using a Macintosh PowerPC model or 68K Macintosh with 68020 or better processor.    You 
must also have a sound card with speakers and a microphone. For your recipients to play your 
messages, they must have the PureVoice Player-Recorder installed on their 32-bit Windows 95/98/NT
machine or their Macintosh PowerPC or 68K Mac, with a sound card and speakers. Additionally, if 
they wish to record a response, they must have a microphone. Your recipients can download the 
PureVoice Player-Recorder or Plug-In for free from this Web site: 
<http://eudora.qualcomm.com/purevoice/>.



The PureVoice Advantage: Voice Quality

PureVoice voice-messaging software — in Player-Recorder or Plug-In form — is a product of 
QUALCOMM Incorporated.

QUALCOMM is the developer of CDMA, or “Code Division Multiple Access,” a technology that has 
become the new North American standard for digital wireless communications, and is fast becoming the 
world’s premier standard for wireless telephony: CDMA is in use in digital wireless telephone systems and
phones around the world.

QUALCOMM is also the maker of Eudora electronic mail software, the world’s number one Internet e-mail
software, now in use by over 18 million users in its two versions, Eudora Pro and Eudora Light.

QUALCOMM has combined the need for Internet-based voice messaging with the need for high-quality 
speech to create PureVoice. PureVoice uses the same state-of-the-art, proprietary voice-encoding 
technology that QUALCOMM developed for use in its CDMA digital wireless communication systems. 
Thus, a message composed with PureVoice has the same high sound quality as the world’s best wireless
telephones. A PureVoice voice message very nearly approaches the sound quality experienced in a local 
phone call made over a good-to-high-quality home telephone.

For more information on PureVoice™, SmartRate™, CDMA, or QUALCOMM Incorporated, please visit 
our Web sites, <http://www.qualcomm.com> and <http://eudora.qualcomm.com>. Once there, search for 
the topic of your choice.

For additional product and licensing information on QUALCOMM’s PureVoice Player-Recorder and 
PureVoice Plug-In, please submit message at <http://eudora.qualcomm.com/purevoice/bugs.html>.



A Tour of the PureVoice Window

Shown below is a sample of the open PureVoice window:

The PureVoice window consists of these elements, roughly from top to bottom:

· Title bar, with title and four buttons: Window menu (left), and Minimize, Maximize, and Close (right).

· Menu bar, with four menus: File, Control, Options, Help.

· Toolbar, with buttons: NEW, OPEN, INS, NAME, VOL, TOP.

· Name box (when visible): Lets you edit the file name to be used for the saved voice message.

· Digital display (green LED readout): Shows your current position in the voice message, the total 
duration of the message, the volume level during record and playback, icons indicating operation 
mode (record/play, pause, and compressing), the compression rate, the estimated size of the 
compressed voice message (in kilobytes), and the current playback speed.

· Attach button: Attaches the saved, compressed voice message to an e-mail message.

· Position slider: Shows the current position in the voice message during playback. Can also be moved 
to your desired position for message editing and playback.

· Record/playback control buttons: Play, Record, Stop, Pause, Skip Backward, Skip Forward, Speed 
Up, Slow Down.

· Volume controls (when visible): Sliders let you increase or decrease the speaker volume during 
playback and the microphone volume/sensitivity during recording.

· Status bar: Displays informational and status messages and brief help text for PureVoice window 
items.



The Title Bar

The title bar consists of the window title and four buttons:

· Title – Grab the title bar by the title, with the mouse, and drag it to move the PureVoice window on 
your desktop. The title shows “QUALCOMM PureVoice” when the voice buffer is empty. When a 
voice message is loaded into the PureVoice window, the title shows the file name of that message.

· Window menu button – Click this small icon in the upper left corner of the PureVoice window to 
access the PureVoice window menu. This menu lets you move, minimize, restore, and close the 
PureVoice window (closing the window exits the program).

· Minimize button – Click this small icon in the upper right corner of the PureVoice window to reduce 
the window to an icon on the taskbar or desktop. Click the taskbar icon or double-click the desktop 
icon to return the PureVoice window to its normal size.

· Maximize button – Not available. The PureVoice window is meant to remain at a fixed size, and 
cannot be enlarged to fill the screen.

· Close button – Click this small icon with an “x” in it, in the upper right corner of the PureVoice 
window, to close the PureVoice window and exit the PureVoice program. If the current recording is 
unsaved, you are asked if you want to attach it to an e-mail message before quitting.



The Menu Bar

The menu bar contains four menus:

· File – Use these commands to begin a new voice message, open an existing voice message, save a 
voice message, and attach a voice message to an e-mail message.

· Control – Use these commands to control playback and recording.

· Options – Use these commands to select the compression rate, the recording mode, the show/hide 
status of the volume controls, and the hierarchy of the PureVoice window on your desktop (whether or
not it will remain the frontmost window among all windows at all times).

· Help – Use these commands to get online help for QUALCOMM’s PureVoice.



The Toolbar

The toolbar contains pushbuttons giving you easy access to frequently used menu commands:

· NEW – Erases the current recording so that you can start a new voice message. Asks you to confirm 
the erase.

· OPEN – Opens an existing voice-message file for playback or editing. Displays a standard file 
selection dialog.

· INS – Turns Insert Mode on and off. Insert Mode lets you add recorded material to your message by 
inserting it (splicing it) between other content in the message, without overwriting any existing 
material. When the button is popped out, recording is in Overwrite Mode: newly recorded material 
overwrites all material from the current position in the voice message to the end of the message. See 
the discussion of Recording Modes.

· NAME – Shows/hides a name box that lets you edit the file name to be used for the saved voice 
message.

· VOL – Shows/hides the volume controls, whose sliders let you regulate the volume of the speaker 
during playback and the volume/sensitivity of the microphone during recording.

· TOP – Turns on and off the Always Stay On Top feature, which lets you always keep the PureVoice 
window at the top of the stack of windows on your desktop, even when another window is active. With
the feature off, the PureVoice window moves behind other windows when they are made active.



The Name Box

This text-editing box can be shown or hidden by pressing the NAME toolbar button or by selecting Edit 
Name from the Options menu.

The name box displays the file name that will be used when you save the current voice message. When 
you start a new message, PureVoice assigns a default name based on the date and other information. 
You can change the name in the box.

When you save the voice message, PureVoice adds the extension .QCP to the end of the file name, to 
indicate a “QUALCOMM PureVoice” file.

The name box opens just below the toolbar and can be hidden from view to save space on your desktop.



The Digital Display

The green digital LED readout in the middle of the PureVoice window displays these items of information:

· The current position within the voice message, expressed as H:MM:SS (hours, minutes, seconds).

· The total duration of the voice message, expressed as H:MM:SS (hours, minutes, seconds).

· The record/play volume level, shown only during record or playback. A series of dots appears across 
the bottom of the display, from left to right. Green dots indicate that the volume is within the safe level 
of the microphone’s sensitivity; yellow dots that the volume is approaching distortion; red dots that the
voice is too loud for the microphone’s sensitivity and that distortion is present. Red dots indicate that 
the microphone volume is set too high or that you are speaking too loudly or leaning too close to the 
microphone.

· Three icons under the large “Q” that appear only during record or playback and indicate the 
operational mode. The leftmost icon is a flashing red spot during recording and a steady green right-
arrow during playback. The middle icon shows two vertical bars indicating pause and appears only 
when pause is on. The rightmost icon is a “C” that appears only during recording and indicates that 
the voice message is being compressed.

· The compression rate: Initial values of 13 kb/s indicates PureVoice, 8 kb/s indicates SmartRate option
settings.    As soon as the recording starts, it displays the up-to-date average bits per second.    When 
a playing a recorded file, it displays the compression rate of the entire file.    It could range any where 
between 1kb/s and    13kb/s.

· The total estimated size of the compressed voice message, in kilobytes (1K = 1,024 bytes).

· The playback speed, from slow to fast over seven levels, with the middle level being the normal or 
standard rate. Note: Recording takes place at one speed only.



The Attach Button

Press this button, located next to the digital display, to attach the current voice message to an e-mail 
message.

If you are using the Eudora plug-in version of PureVoice: When you press this button, PureVoice 
automatically opens a new Eudora e-mail message (if one is not already open) and attaches the voice 
message to the e-mail message, leaving you in the composition window. PureVoice names the 
attachment with either the default file name or the file name you have assigned, adding the .QCP 
extension.

If you are using the standalone version of PureVoice with either Eudora or an e-mail software application 
that works with MAPI: When you press this button, PureVoice automatically launches your default e-mail 
application, if it is not already launched (you must specify this default the first time you use the PureVoice 
application), then opens a new e-mail message (if one is not already open) and attaches the voice 
message to it. PureVoice leaves you in the composition window, and names the attachment according to 
the convention described above.

If you are using the standalone version of PureVoice with an e-mail software application that does not 
work with MAPI: You will not be able to use the Attach button for automatic attachment of the voice 
message to an e-mail message. If you press the Attach button, an error message will appear. You must 
cancel and use attachment method 2 described in Attaching a Voice Message to an E-mail Message (you
must save the voice message to a file and then attach the file to an e-mail message using standard 
attachment methods in your mailer, such as drag and drop).



The Position Slider

This slider, which moves through a horizontal scale under the digital display, indicates the current position
within the voice message during playback. You can also drag this slider to change position for message 
editing and playback.

During playback, the slider moves from the beginning of the scale to the end of the scale as the voice 
message plays back from beginning to end. During recording, the slider is inactive.

You can drag the slider to any position within the current voice message and begin recording or playback 
from that position. You can also click inside the scale to move the slider in discrete jumps.



The Record/Playback Control Buttons

The record/playback control buttons are arrayed on a horizontal, VCR-like panel near the bottom of the 
PureVoice window. This panel has six standard control buttons and two playback-speed buttons (marked 
SP):

· Play – Starts playback from the current position in the voice message, marked by the position slider.

· Record – Starts recording from the current position in the voice message, marked by the position 
slider. Recording behavior differs depending on whether Insert Mode is turned on or off. See the 
discussion of Recording Modes.

· Stop – Stops playback or recording and returns to the beginning of the voice message. Note: When 
you press Stop, PureVoice returns to the beginning of the message; if you then record in Overwrite 
Mode (Insert Mode off), you will erase the message just recorded. Be sure to save it first, if desired.

· Pause – Pauses during playback or recording. (In playback mode, the position slider stops in 
position.) Press the Pause button again to resume playback or recording.

· Skip Backward – Jumps backward, toward the beginning of the voice message, one-tenth of the total
message length with each press. Not available while recording.

· Skip Forward – Jumps forward, toward the end of the voice message, one-tenth of the total message
length with each press. Not available while recording.

· Speed Up – Increases the playback speed by one level. There are seven playback speeds, with the 
middle speed being normal or standard playback. Fast playback removes much of the empty space 
between spoken words; thus, there is no distortion in the pitch or character of the voice. Use this 
control for rapid review of voice messages.

· Slow Down – Decreases the playback speed by one level. Slow playback stretches out the empty 
space between spoken words, and also the words themselves, but without distorting the voice pitch or
character. Use this control for detailed pinpointing of data within voice messages.

Note:

Press the spacebar to operate the current default record/playback control button: this is the button 
highlighted with a dashed box around it. The default changes as you perform different operations.



The Volume Controls

You can show or hide these controls by pressing the VOL button on the toolbar or by selecting Volume 
Controls from the Options menu. The sliders let you increase or decrease the volume of the speaker 
during playback and the volume/sensitivity of the microphone during recording. The controls open on the 
right of the PureVoice window, and can be hidden to save space on your desktop.

To work either volume control, drag the slider up or down with the mouse to increase or decrease 
the volume smoothly; or click in the scale in which the slider moves to increase or decrease the volume in
jumps.
The two controls are as follows:

· Speaker Volume – Controls the output of the computer’s speaker during playback.

· Microphone Volume/Sensitivity – Controls the volume/sensitivity of the computer’s microphone 
during recording. If you move this slider to the top, the microphone is very sensitive to volume: 
speaking loudly or leaning in too close to the microphone will cause voice distortion. If you move this 
slider to the bottom of the control, the microphone will be very insensitive to volume, and you will have
to speak very loudly into the microphone, or lean in very close, to have your voice recorded.



The Status Bar

The status bar, located at the bottom of the PureVoice window, displays informational and status 
messages during operation. It also displays brief help messages for a variety of objects you click on or 
select in the PureVoice window. “Ready” indicates that the PureVoice program is ready to record or play 
a voice message.



The PureVoice Window Menu

Click the small icon in the upper left corner of the PureVoice window to open the PureVoice window 
menu. This menu lets you manipulate the PureVoice window and exit the program. Here are the 
commands:

· Restore – Restores the PureVoice window to its normal size from a minimized icon on the taskbar or 
desktop. This option is unavailable when the PureVoice window is already at normal size.

· Move – Lets you use the keyboard arrow keys to move the PureVoice window. Select this command 
and the pointer changes. Move the window with the keyboard arrow keys, then press Enter to 
complete the move.

· Size – Not available. The PureVoice window is meant to remain at a fixed size, and cannot be sized 
up or down (other than being minimized).

· Minimize – Reduces the PureVoice window from its normal size to an icon on the taskbar or desktop. 
Click the taskbar icon or double-click the desktop icon to return the PureVoice window to normal size. 
This option is unavailable when the window is already minimized.

· Maximize – Not available. The PureVoice window is meant to remain at a fixed size, and cannot be 
enlarged to fill your screen.

· Close – Closes the PureVoice window and exits the PureVoice program. If the current message is 
unsaved, you are asked if you want to attach it to an e-mail message before exiting.



The File Menu

Use the File menu to start a new voice message, open an existing voice file for playback or editing, save 
a voice message to a file, and attach a voice message to an e-mail message.

· New Recording – Erases the current message so that you can start a new voice message. Selecting 
this command erases the recording “buffer,” which is an area in your computer’s memory that is 
reserved for voice recordings. If there are any unsaved changes, you are asked to confirm the erase. 
Selecting New Recording is like erasing a cassette tape before taping over it. You start with a “fresh” 
recording area. Note that this is a preliminary step for recording, and you must then press the Record
button or select Record from the Control menu to start the actual recording. Also note: If the position 
slider is at the beginning of the message, and you are in Overwrite Mode (Insert Mode off), there is no
need to select New Recording — when you press Record, the previous message is erased — but 
you are not asked to confirm the erase.

· Open… – Opens an existing voice-message file so that you can play it back or modify it. When you 
select this command, a standard file selection dialog is displayed. There are two types of files you can
open: a QUALCOMM PureVoice file, which has the extension .QCP, and an 8 kHz (16-bit) PCM 
Wave file having the .WAV extension.

· Save As… – Saves the current voice message to a file. When you select this command, a standard 
Save As dialog is displayed. The file name used is the name appearing in the PureVoice window’s 
name box — either the default file name assigned by PureVoice, or the name you’ve defined — with 
the .QCP extension added, for QUALCOMM PureVoice file. You can change the file name here if 
desired. When the voice buffer is empty, the Save As… command is unavailable — there is nothing to
save.

· Attach – Attaches the current voice message to an e-mail message. Operates exactly the same as 
the Attach button next to the digital display. See also Attaching a Voice Message to an E-mail 
Message.

· Exit  – Closes the PureVoice window and exits the PureVoice program. If the current message is 
unsaved, you are asked if you want to attach it to an e-mail message before exiting.



The Control Menu

Use the Control menu to control playback and recording operation. These commands have the identical 
functions as the buttons on the VCR-like panel of control buttons near the bottom of the PureVoice 
window.*

· Play – Starts playback beginning at the current position in the voice message, as marked by the 
position slider.

· Record – Starts recording (in Insert Mode or Overwrite Mode) beginning at the current position within 
the voice message, as marked by the position slider. See the discussion of Recording Modes.

· Stop – Stops playback or recording and returns to the beginning of the voice message. Note: When 
you select Stop, PureVoice returns to the beginning of the message; if you then select Record while 
in Overwrite Mode (Insert Mode off), you will erase the message just recorded. Be sure to save it first,
if desired.

· Pause – Pauses during playback or recording. (In playback mode, the position slider stops in 
position.) Select Pause again to resume playback or recording.

· Skip Backward – Jumps backward, toward the beginning of the voice message, one-tenth of the total
message length. Not available while recording.

· Skip Forward – Jumps forward, toward the end of the voice message, one-tenth of the total message
length. Not available while recording.

· Speed Up – Increases the playback speed by one level. This speeds up playback without distorting 
voice pitch or character. Use for quick review of voice messages.

· Slow Down – Decreases the playback speed by one level. This slows down playback without 
distorting voice pitch or character. Use for detailed pinpointing of data within a voice message.

· Volume … Speaker Vol Up – Increases the output of the computer’s speaker during playback.

· Volume … Speaker Vol Down – Decreases the output of the computer’s speaker during playback.

· Volume … Microphone Vol Up – Increases the volume/sensitivity of the computer’s microphone 
during recording.

· Volume … Microphone Vol Down – Decreases the volume/sensitivity of the computer’s microphone 
during recording.

* You can press the spacebar to operate the current default record/playback control button: this is the 
button highlighted with a dashed box around it. The default changes as you perform different 
operations.



The Options Menu

Use the Options menu to control the compression rate, the recording mode, the visibility of the volume 
controls, and the visibility of the PureVoice window on your desktop.

· PureVoice (Superior Quality) – Records your voice at extremely high quality while using a low 
compression rate. You must choose either PureVoice or SmartRate before recording a voice 
message. Use PureVoice when quality is paramount and you can afford the slightly larger file size 
and its results: takes a little more space on your computer and your recipient’s computer, and 
transmits a little more slowly over e-mail. A message recorded using PureVoice has a sound quality 
comparable to that of a local phone call made from a good-quality home telephone.

· SmartRate (Smaller File Size) – Records your voice at very high quality while using a high 
compression rate, which results in a smaller file with little sacrifice to quality. You must choose either 
SmartRate or PureVoice before recording a voice message. Use SmartRate when file size and 
transmission rate are of paramount importance and you can afford a slight drop in quality. A message 
recorded using SmartRate has a sound quality almost as good as that in a local phone call made from
a good-quality home telephone, and substantially better than a long-distance call made from such a 
phone. The saved, compressed voice message takes up less space on your computer and your 
recipient’s computer, and transmits faster over e-mail.

· Insert Mode – Turns Insert Mode on and off. When Insert Mode is on, newly recorded material is 
inserted between existing material in the voice message, at the current position. The inserted material
“squeezes” between the other material at the point of insertion. When Insert Mode is off, the 
PureVoice Player-Recorder uses the default recording mode of Overwrite Mode, in which recorded 
material overwrites any existing recorded material under it, from the current position to the end of the 
voice message. To compare Insert Mode to tape-recording, imagine cutting a piece of audiotape and 
then splicing (inserting) a strip of tape between the two cut ends. Recorded material is preserved on 
either side of the splice. For more information, see the discussion of Recording Modes.

· Edit Name – Shows and hides the name box, which lets you edit the file name to be used for the 
saved, compressed voice message. File names entered in the name box are automatically assigned 
the extension .QCP at save time, for QUALCOMM PureVoice file.

· Volume Controls – Shows and hides the record/playback volume controls. These sliders let you 
increase and decrease the volume of your computer’s speaker during playback and the 
volume/sensitivity of your computer’s microphone during recording. Drag the sliders up and down 
with the mouse, or click in the scales in which they slide to move them in jumps.

· Always Stay On Top – With this option checked, the PureVoice window always stays at the top of the
stack of windows on your desktop, even when another window is active. With the option unchecked, 
the PureVoice window moves behind other windows when you make them active.

· Attach Site Info – With this option checked, information on how to download the PureVoice Player-
Recorder application will be attached to email messages with PureVoice message.

· Compact View – When this option is checked, the PureVoice Player-Recorder application displays 
only a select group of buttons.    When it’s in a Compact View mode, play back speed buttons will be 



replaced by a Normal View    button.      You can also go back to Normal View with Control+V or double
clicking the mouse.    Right mouse button will display the menu options in Compact View mode.



The Help Menu

Use the Help menu to get online help for QUALCOMM’s PureVoice Player-Recorder.

· Topics – Displays the Help window, which lets you select topics for help information, look up 
keywords in an index, and search for specific words in online help text.

· About PureVoice – Displays copyright and version information for QUALCOMM’s PureVoice.    The 
“Visit Web Site” button opens a web browser application and goes to PureVoice web site.    The “Bug 
Report” button opens a web browser application and goes to PureVoice Bug Report site.



Getting Help

To get online help for the PureVoice software, do the following:

1. Select Topics from the Help menu.

2. Click the Contents tab to get help by topic. Double-click on a closed-book icon to open the book and 
see the topics in that book. Double-click on a topic title (question-mark icon) to open a help window 
containing text for that topic. To print any topic in the Contents window, select the topic and click the 
Print… button. If you select a book icon and click Print…, all topics within that book will be printed.

3. Click the Index tab to search for help by keywords — these are words contained in a special Index 
created for the online help. Double-click on an index entry, or type the first few letters in the text box 
to navigate to that entry, then double-click on it. If a Topics Found box appears, it contains multiple 
topics where that keyword can be found. Choose a topic and double-click on it. The help for that topic 
displays.

4. Click the Find tab to search for help by any word or phrase contained in the online help, or by any 
topic title contained in the collection of online help topics. The first time you click Find, the Find Setup 
Wizard asks you to set up a list containing every word in the online help. Follow the instructions in the
Setup Wizard. When you are finished, you will have a search list of words and a complete list of help 
topics. Double-click on any word or topic to find related online help information.

5. To get context-sensitive help on the online help window itself, click the question mark in the upper 
right corner of the help window. The pointer now carries a question mark with it. Now click on any item
in the window to get help on that item. You can do this whether you are in the Contents, Index, or Find
windows. (This help is provided by Microsoft. Some items in these windows do not carry context-
sensitive help.)

6. For more help on using the windows that display containing the online help text, see the Microsoft 
Windows documentation provided with your computer. Look for documentation on Microsoft Windows 
Help (WinHelp).

Note:

To get copyright and version information for QUALCOMM’s PureVoice, select About PureVoice from the 
Help menu.



Recording a New Voice Message

To record a new voice message, take these steps:

1. Press NEW or select New Recording from the File menu. This clears the voice buffer (the area of 
computer memory reserved for voice recordings). You are asked if you wish to discard the current 
recording, if one exists. Click Yes to continue. (If not, click No and save the current recording.) Note: 
This step does not begin the recording.

2. Press the Record button, or select Record from the Control menu. Recording begins.

3. Speak clearly into the computer’s microphone. Observe the volume indicator in the digital display, 
and if necessary, adjust the microphone volume/sensitivity control.

4. When you are finished recording, press the Stop button or select Stop from the Control menu.

5. You can now play back the message, or save the message to a file, or attach the message to an e-
mail message.

6. To discard the message and start over again, press NEW or select New Recording from the File 
menu and repeat the steps above.



Playing Back a Voice Message

To play back the current voice message stored in the voice buffer, if such a message exists:

Press the Play button or select Play from the Control menu.
The message plays back from beginning to end. Use the Stop, Pause, Skip Backward, Skip 

Forward, and playback speed buttons to control playback, as well as the position slider to control position.
(You can play back from a particular point by dragging the slider before pressing Play.) Adjust the 
speaker volume control if necessary.
There are three ways to play back a voice message stored as a file on your computer: open, drag and 
drop, and double-click. The file must be stored as a QUALCOMM PureVoice file (.QCP) or as an 8 kHz 
(16-bit) PCM Wave file (.WAV).

In each method, if a recording currently exists in the voice buffer, you are first asked if you want to discard
it. Click Yes to continue. If not, click No and save the current recording.

During playback, use the playback control buttons discussed above, or the items on the Control menu. 
Also note: The spacebar controls operation of the current default record/playback control button, which 
is highlighted on your screen by a dashed box around it.

Standard Open-file playback:

1. In the PureVoice window, press OPEN or select Open… from the File menu.

2. In the file-selection dialog, select the voice-message file to open. As soon as you complete your 
selection, the voice message begins playing back.

Drag and drop playback:

Drag and drop a voice-message file into the open PureVoice window, or onto the PureVoice 
window icon when it has been minimized on the desktop (but not on the taskbar).
Double-click playback:

Double-click on a voice-message file icon on the desktop to begin playback of the message.
OR

If you receive a voice message as an attachment to an e-mail message, open the e-mail 
message and, if the voice-message attachment icon is visible and your e-mail software lets you, double-
click on the icon to begin playback.



Editing an Existing Voice Message

To edit an existing voice message, take the following steps:

1. If the voice message you wish to edit is the current message stored in the voice buffer, go to the next 
step. Otherwise, press OPEN or select Open… from the File menu and select the voice file you wish 
to edit. (You can only edit a .QCP file or an 8 kHz [16-bit] PCM .WAV file.)

2. Turn Insert Mode on or off, depending on whether you want to insert recorded material or overwrite 
existing material. (See the discussion of Recording Modes.) Use the INS button or the Insert Mode 
command on the Options menu.

3. Move the position slider to the position within the voice message at which you wish to begin recording
the new material. Or, begin playback and then press Pause at the point at which you want to begin 
recording. Use the Skip Backward, Skip Forward, and playback-speed buttons to review the message
beforehand if necessary.

4. Once the slider is set to the proper position, press Record. Speak clearly into the microphone.

5. When you are finished recording your inserted or added material, press Stop.

6. To play back the edited message and hear the results, press Play. To discard the message and start 
over again, go back to step 1 and open the existing voice file.



Saving a Voice Message to a File

If you have just recorded a new voice message or edited an existing message, here’s what to do to save 
the message to a file on your computer:

1. Select Save As… from the File menu.

2. In the Save As dialog, specify the file name you want to use for the saved file, making sure to add 
the .QCP extension.

3. Click Save in the Save As dialog.

The voice message is saved as a QUALCOMM PureVoice file.

Notes:

· When you select Save As…, PureVoice automatically assigns the file name in the Save As dialog: 
this is whatever appears in the PureVoice window’s name box at the time of save, plus the .QCP 
extension. The name box typically contains either a default name assigned by PureVoice (in the case 
of a new recording), or a custom name you’ve entered, or the name of a file you recently opened for 
playback. Simply change the file name in the Save As dialog, if desired. To show or hide the name 
box in the PureVoice window, press the NAME button or select Edit Name from the Options menu.

· If a file already exists with the file name you specify in step 2, you are asked in step 3 if you want to 
replace the old file with the new one. Click Yes to replace. Click No to cancel; you can then specify a 
different name and click Save.

· Save As… is unavailable on the File menu when the voice buffer is empty (no message to save).



Attaching a Voice Message to an E-mail Message

Method 1: Eudora Pro, Eudora Light, cc:Mail, Microsoft Exchange, Microsoft Mail, Other MAPI 
Mailers

To attach a voice message to an e-mail message in Eudora Pro, Eudora Light, or any e-mail software 
application that works with MAPI, including cc:Mail, Microsoft Exchange, and Microsoft Mail, take the 
following steps:

1. If the voice message you wish to attach is the current message stored in the voice buffer, go to the 
next step. Otherwise, open your desired voice message by pressing OPEN or selecting Open… from 
the File menu, and then choosing the file.

2. Press the Attach button in the PureVoice window (next to the digital display), or select Attach from 
the File menu.

PureVoice launches your e-mail application (if it is not already launched), opens a new e-mail 
message (if one is not already open), and attaches your voice message to the e-mail message, 
leaving you in the composition window of the e-mail message.

Method 2: AOL, CompuServe, Netscape Mail, Other Non-MAPI Mailers

To attach a voice message to an e-mail message composed using any e-mail software application that 
does not work with MAPI, including AOL, CompuServe, and Netscape Mail, take the following steps:

1. Save the voice message to a file on your computer, using the Save As… command on the File menu.

2. Attach the voice-message file to an e-mail message created with your e-mail software, using the 
standard method for attaching files to e-mail messages in that software. For example, your e-mail 
software may let you drag and drop the file into an open new message.

Notes:

· In either method above, your recipients must have QUALCOMM’s PureVoice Player-Recorder 
installed on their system in order for them to play back a PureVoice (.QCP) file.

· In Method 1, if you are using the Eudora plug-in version of PureVoice, Eudora will already be 
launched; PureVoice will open a new message (if one is not already open) and attach the voice 
message to it.

· The first time you perform the procedure in Method 1, PureVoice asks you to choose your default e-
mail software application. If you choose Eudora or a mailer that works with MAPI, PureVoice will 
proceed. If you choose a mailer that does not work with MAPI, PureVoice will not proceed: you will 
need to cancel and perform Method 2 if you wish to use that mailer.

· A quick way to perform Method 1 with a stored voice file is this: double-click on the file, or drag and 
drop it into the PureVoice window; when it begins playing, stop it; then press Attach or select Attach 
from the File menu: the voice message will be attached to an e-mail message as above.

· MAPI, which stands for “Messaging Application Program Interface,” is special software that comes 
built into a variety of software applications, e-mail and otherwise, and lets you attach a file and send 
an e-mail message from the software you’re currently working in. For example, you can be in a word 



processing document, a spreadsheet, a graphics file, or the PureVoice window, and you press a 
button or select a menu command: an e-mail message is automatically opened (in your default e-mail 
software) and the document you’re currently working on is attached to that message. If your e-mail 
software uses MAPI, you can press the Attach button in the PureVoice window to automatically 
attach your voice message to an e-mail message, as in Method 1 above. If your e-mail software does 
not work with MAPI, pressing the Attach button causes an error message to appear, and you must 
cancel and perform Method 2 above.



Converting a PureVoice(.qcp) file to a .wav file 

To convert a PureVoice(.qcp) file to .wav file, press the Alt+Shift+C keys in PureVoice.      You can also 
convert a .wav file to a PureVoice file by pressing the same Alt+Shift+C keys.      This conversion works 
with 8 kHz (16-bit) PCM .wav files.



Adding a PureVoice button in Eudora

To add a PureVoice button to the Eudora Pro toolbar, place the cursor on the toolbar and click the right 
mouse button, then select Customize from the menu.    The Customize Toolbar dialog is displayed. Select 
Message from the Category list, then drag the “Attach files to this message” button onto the toolbar.    
Release the mouse button and select PureVoice from the menu.

Clicking on this customized PureVoice button launches PureVoice the same as the Message -> Attach -> 
PureVoice menu option.



Setting the MAPI option in Eudora 

To use PureVoice as a MAPI, application with Eudora, you must have Eudora Pro or Eudora Light MAPI 
option set to ‘When Eudora is running’ or ‘Always’ in the MAPI section of Options menu.



Shortcut Keys

The following keyboard shortcuts can be used in place of the listed commands:

Always Stay
      On Top

Ctrl+T

Attach Ctrl+A

Attach Site Info Ctrl+D

Compact View Ctrl+V

Close Alt+F4

Edit Name Ctrl+E

Exit Ctrl+Q

Insert Mode Insert

Microphone Vol Up }

Microphone Vol Down {

New Recording Ctrl+N

Open… Ctrl+O

Pause F8

Play F5

Record F6

Save As… Ctrl+S

Skip Backward <

Skip Forward >

Slow Down -

Speaker Vol Up ]

Speaker Vol Down [

Speed Up +

Stop F7

Volume Controls Ctrl+G

Note:

You can also use the spacebar to operate the current default record/playback control button on the VCR 
panel at the bottom of the PureVoice window. The “current default” button is the one highlighted with a 



dashed box around it.



Recording Modes: Insert vs. Overwrite

The PureVoice Player-Recorder records in two modes: Insert Mode and Overwrite Mode.

Insert Mode is turned on and off by pressing the INS button on the toolbar or by selecting Insert Mode 
from the Options menu. When Insert Mode is off, Overwrite Mode is on by default.

When you record in Insert Mode, newly recorded material is inserted into the voice message beginning at 
the position marked by the position slider. The new material is “squeezed” between existing material — 
none of the existing material is lost.

To compare Insert Mode to tape-recording, imagine cutting a piece of audiotape (at the insertion point) 
and splicing (inserting) another strip of tape between the two cut ends. The spliced strip represents the 
inserted recording. Material is preserved on either side of the splice.

Suppose you record a new voice message, “One, two, three, four, five.” Suppose you then turn on Insert 
Mode, move the position slider to just after “three,” and record, “a, b, c.” When you play this back you will
hear, “One, two, three, a, b, c, four, five.” The “a, b, c” is inserted between the “One, two, three” and the 
“four, five” without losing any previously recorded material.

When you record in Overwrite Mode (Insert Mode turned off), newly recorded material overwrites 
everything in the voice message from the current position, marked by the position slider, to the end of the 
message. You can think of this mode as “erase from here to the end and append.”

Suppose you turn Insert Mode off and record a new voice message, “One, two, three, four, five.” You then
move the position slider to just after “three” and record “a, b, c.” Now when you play this back you will 
hear, “One, two, three, a, b, c.” The “four, five” part has been overwritten by the newly recorded material. 
Even if you had recorded “four, five, …, one hundred” in the original message, that entire part would have
been overwritten by the “a, b, c.”

Using Insert Mode you can also add material at the beginning of a voice message (“prepended” material).
Just turn on Insert Mode, move the position slider to the beginning of the message, and begin recording.

You can add material to the end of a voice message (“appended” material) in either Insert Mode or 
Overwrite Mode — since there’s no material after the end of the message, there’s nothing to overwrite. 
Just select your recording mode, move the position slider to the end of the message, and start recording.



Easy Playback Methods

The easiest playback methods are double-click and drag and drop.

Double-click on a voice file on your desktop to play the message. Or, if the message comes in as an 
attachment to an e-mail message, open the e-mail message and double-click on the voice-file attachment
icon in the message (if your e-mail software lets you do this).

You can also play back a voice file by dragging and dropping it into the open PureVoice window, or 
dropping it onto the PureVoice window icon when it is minimized on the desktop (but not on the taskbar).

In either method above, if the voice buffer is empty, the voice file begins playing the moment you 
complete the action: double-click or drop. If, however, PureVoice is open and a current recording exists in 
the voice buffer, you are asked if you want to discard the recording (if it is unsaved), since the new voice 
message will erase it. Once you confirm, the message begins playing.

Remember that the only two types of files you can play back in PureVoice are QUALCOMM PureVoice 
files, with the .QCP extension, and 8 kHz (16-bit) PCM Wave files, with the .WAV extension.



What If I Can’t Record a Voice Message?

To record a voice message using PureVoice, your Windows 95/98/NT computer must be equipped with a 
sound system including a sound card and a microphone. In order for you to hear your message on 
playback, your computer must also have speakers.

If you are unable to record your voice, perform the following checks:

1. Make sure your computer’s sound card is working properly. Please refer to your hardware 
documents.

2. Make sure your computer’s microphone is correctly connected to the computer.

3. Make sure you are not running any other software application that uses the computer’s microphone.

4. Make sure the microphone volume/sensitivity level is set correctly in the PureVoice window. Press the
VOL button in the window to display the volume settings, then try increasing the microphone 
volume/sensitivity setting by dragging upward the slider above the microphone icon. If this setting is 
too low, your voice may not be recorded loudly enough for you to hear on playback.

5. Remember that pressing NEW or selecting New Recording from the File menu does not start the 
recording. It merely erases the voice buffer. You must still press the Record button or select Record 
from the Control menu to start your recording.



What If I Can’t Play Back a Voice Message?

To play back a voice message using PureVoice, your Windows 95/98/NT computer must be equipped with
a sound system including a sound card and speakers. (Additionally, to record a message, your computer 
must have a microphone.)

Note: There are only two kinds of voice messages you can play back: a QUALCOMM PureVoice 
message having the .QCP extension, and an 8 kHz (16-bit) PCM Wave file having the .WAV extension 
(note that not all .WAV files can be played back!). If the voice file is not one of these two types, you will 
not be able to play it back with PureVoice.

If you are unable to play back a voice message of one of the above two types, perform the following 
checks:

1. Make sure your computer’s sound card is working properly. Please refer to your hardware 
documents.

2. Make sure your computer’s speakers are correctly connected to the computer.

3. Check the computer’s speaker-volume controls (hardware controls and software controls).

4. Make sure the speaker volume level is set correctly in the PureVoice window. Press the VOL button in
the window to display the volume settings, then try increasing the speaker volume level by dragging 
upward the slider above the speaker icon. If this setting is too low, you might not be able to hear the 
voice message on playback.

5. Is the voice buffer empty? If so, there is nothing to play back. Remember that a voice message is 
loaded into the voice buffer and played back in one of four ways: either you’re playing back a 
message that you’ve just recorded in the PureVoice window, or you open an existing voice file (press 
OPEN or select Open… from the File menu), or you double-click on a voice file on your desktop (or in
an e-mail message), or you drag and drop a voice file into the PureVoice window or onto its 
minimized icon.

6. Is the PureVoice window in Pause mode?



What If my PC hangs when I select Attach?

If your PC hangs when you select Attach, this may be because your PC’s MAPI, setting is incorrect.    
Check your e-mail MAPI setting to avoid this problem.

For Eudora Pro or Eudora Light users, see: Setting the MAPI Option in Eudora, We recommend using the 
Message -> Attach -> PureVoice menu option    to launch PureVoice.



What If wrong e-mail program launches when I select Attach?

If the wrong e-mail software launches when you select Attach, you need to disable its e-mail MAPI setting 
and enable the desired e-mail MAPI setting.    Your PC can have only one designated MAPI, server(e-
mail).

For Eudora Pro or Eudora Light users, see section: Setting the MAPI Option in Eudora, We recommend 
using the    Message -> Attach -> PureVoice menu option to launch PureVoice.



PureVoice no longer records ever since Win98 was installed

Check the Mixer(or Recording Control) settings to make sure the Microphone is selected for Audio Input. 
PureVoice is Win 98 compatible. 



PureVoice skips parts of the messages when I play

Try the following:

1. Download PVQT.qcp file (12,926 bytes) from <http://eudora.qualcomm.com/purevoice/bugs.html>.

2. Load the PVQT.qcp file into PureVoice application.

3. Play the PVQT.qcp file.    If it plays OK, your PC/Sound Card supports PureVoice decoding(playing)

4. Download PVQT.wav file (144,056 bytes) <http://eudora.qualcomm.com/purevoice/bugs.html>. 

5. Load the PVQT.wav file into PureVoice application. The display on the PureVoice will say 128kb/s

6. Hit Alt+Shift+C (altogether), to convert .wav to PureVoice format. You'll see the "Converting: X% 
Done" on the status line, while it's converting.(Faster your PC, faster the conversion will take)

7. Play the file. If it plays OK, your PC/Sound Card supports PureVoice encoding(recording) from a file 
source.

If your own recorded message is not complete during the playback, that indicates that your Sound Driver 
is not passing all the data into PureVoice for recording. You may want to disable other applications during 
the recording for better performance.



PureVoice caused an invalid page fault in module QCELP.QCL

If you get this error sometimes and other times, you get a pefectly fine recording, then try the following:

1. Start PureVoice

2. Record about one second of message and hit Stop button.(before PureVoice crashes)

3. Hit Alt+Shift+C to convert to PCM format (display will indicate 128kb/s)

4. Record your real message (erasing the first one second)

5. Hit Alt+Shift+C to convert to PureVoice format

6. Attach

This way, you're encoding to PureVoice format from a file rather than from a microphone/sound card 
directly. (Some Crystal Pnp Audio System CODEC seem to have this problem).



PureVoice plays fine, but my recording doesn't have the same quality

First try recording with all other applications termainated. If the quality of the recording hasn't improved, 
then try the following:

1. Start PureVoice

2. Record about one second of message.

3. Hit Alt+Shift+C to convert to PCM format (display will indicate 128kb/s)

4. Record your real message (erasing the first one second)

5. Play back the message 

If this recording sounds better than "real time" recording, your problem may reside in your CPU(AMD 
K6?) and/or sound driver(SoundBlaster clones).



Selecting 'Attach' puts the attachment into a new message

Eudora users should use the Message -> Attach -> PureVoice menu option to attach a PureVoice 
message to a message. With other e-mail programs, selecting 'Attach' always brings up a new 
message(unfortunately, that's how MAPI works). 



It sounds choppy and has a clicking/whipping sound

Usually, this is caused by not having enough CPU cycles for PureVoice for real time decoding on 486 
based machines. Some users with 486/33 MHz with 8 or 16 MB of memory may experience this problem. 
A PC with 486/50 MHz, 8 MB of memory should do fine. Terminating other programs may help to improve 
the sound quality. 



Can't Record with Yamaha OPL3-SA sound system

Even though, this soundcard/driver claims to be Windows compatible 16-bit sound system, it doesn't 
support 8 kHz attribute. This sound system doesn't allow any application (sndrec.exe or PureVoice.exe) to
play or record using 8 kHz. PureVoice requires 8 kHz support from the sound system to work. 

(Note: Yamaha OPL3-SAx users are reporting that this driver supports 8 kHz, but they are experiencing 
"clicking" with PureVoice)

Sample PureVoice voice message (4kb) is available on 
<http://eudora.qualcomm.com/purevoice/bugs.html>.

Sample PCM 8 kHz, 16 bit, Mono .wav voice message (44kb) is available on 
<http://eudora.qualcomm.com/purevoice/bugs.html>.



PureVoice.exe - Unable To Locate DLL

If you're missing one of the following dynamic link library(DLL): MFC40.DLL, MSVCRT40.DLL, 
MFC42.DLL or MSVCRT.DLL. Download PVdll.zip (104kb) file, unzip and place the missing DLL file(s) in 
your system directory(e.g. c:\windows\system, c:\winnt\system32, or any other path that has your system 
level DLL's).



What are the MIME types and Mac file types for PureVoice files?

MIME Media Type name: Audio

MIME Subtype name: vnd.qcelp

File extension: .qcp

Mac Type: celp

Mac Creator: Blad



How can I set PureVoice to attach to Outlook Express?

You'll need to replace the current mapi32.dll file under your system directory(e.g. C:\windows\system or 
C:\winnt\system32) with msoemapi.dll file. (i.e. Copy msoemapi.dll to mapi32.dll)



How can I listen to a PureVoice attachment sent as "winmail.dat" sent by Outlook98?

Tell the Outlook user to use "Plan Text" or "HTML" for Message format. This can be done via Tools-
>Options->Mail Format option settings.



How do I find out what kind of Sound Card I have for my PC?

From "Start" menu, choose Settings -> Control Panel -> Multimedia. Pick "Audio". Your "Preferred device"
settings for "Playback" and "Recording" will be helpful to us when reporting a bug.



Reporting Bugs

If you experience something you think might be a bug in QUALCOMM’s PureVoice, please submit bug 
reports at      <http://eudora.qualcomm.com/purevoice/bugs.html> or you can click on the “Bug Report” 
button on the About PureVoice window under Help. 

Be sure to check the same page for Frequently Asked Questions section and Knowledgebase before you 
report the problem.    When reporting a problem, describe what you did, what happened, what version of 
PureVoice you have (choose About PureVoice from the Help menu), any error messages PureVoice 
gave (the numbers in {}'s are especially important), what kind of computer you have, which operating 
system you're using, and anything else you think might be relevant.

You will receive an automated response indicating that your bug report has been received and forwarded 
to our engineering staff. Unless additional information is needed, you will not receive a direct response.



Requesting New Features

From time to time, everyone comes up with an idea for something they'd like their software to do 
differently. If you come across an idea that you think might make a nice enhancement to PureVoice, your 
input is always welcome. Please submit any suggestions or requests for new features at 
<http://eudora.qualcomm.com/purevoice/bugs.html> or you can click on the “Bug Report” button on the 
About PureVoice window under under Help.

You will receive an automated response indicating that your suggestion has been received and forwarded
to our engineering staff. Unless additional information is needed, you will not receive a direct response.



Licensing and Legal Information

QUALCOMM Incorporated

License Terms for PureVoice™ Player-Recorder Version 1.3 - Windows Platform

License Terms for PureVoice™ Plug-In for Eudora® Version 4.0 - Windows Platform

QUALCOMM grants to the user a nonexclusive license to use this PureVoice software solely for user's 
own personal or internal business purposes. The user may not commercially distribute, sublicense, resell,
or otherwise transfer for any consideration, or reproduce for any such purposes, the PureVoice software 
or any modification or derivation thereof, either alone or in conjunction with any other product or program. 
Further, the user may not modify the PureVoice software.

THE PUREVOICE SOFTWARE IS PROVIDED TO THE USER ''AS IS.'' QUALCOMM MAKES NO 
WARRANTIES, EITHER EXPRESS OR IMPLIED, WITH RESPECT TO THE PUREVOICE SOFTWARE 
AND/OR ASSOCIATED MATERIALS PROVIDED TO THE USER, INCLUDING BUT NOT LIMITED TO 
ANY WARRANTY OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE OR AGAINST 
INFRINGEMENT. QUALCOMM DOES NOT WARRANT THAT THE FUNCTIONS CONTAINED IN THE 
SOFTWARE WILL MEET YOUR REQUIREMENTS, OR THAT THE OPERATION OF THE SOFTWARE 
WILL BE UNINTERRUPTED OR ERROR-FREE, OR THAT DEFECTS IN THE SOFTWARE WILL BE 
CORRECTED. FURTHERMORE, QUALCOMM DOES NOT WARRANT OR MAKE ANY 
REPRESENTATIONS REGARDING THE USE OR THE RESULTS OF THE USE OF THE SOFTWARE 
OR ANY DOCUMENTATION PROVIDED THEREWITH IN TERMS OF THEIR CORRECTNESS, 
ACCURACY, RELIABILITY, OR OTHERWISE. NO ORAL OR WRITTEN INFORMATION OR ADVICE 
GIVEN BY QUALCOMM OR A QUALCOMM AUTHORIZED REPRESENTATIVE SHALL CREATE A 
WARRANTY OR IN ANY WAY INCREASE THE SCOPE OF THIS WARRANTY.

LIMITATION OF LIABILITY - QUALCOMM IS NOT LIABLE FOR ANY CLAIMS OR DAMAGES 
WHATSOEVER, INCLUDING PROPERTY DAMAGE, PERSONAL INJURY, INTELLECTUAL PROPERTY
INFRINGEMENT, LOSS OF PROFITS, OR INTERRUPTION OF BUSINESS, OR FOR ANY SPECIAL, 
CONSEQUENTIAL OR INCIDENTAL DAMAGES, HOWEVER CAUSED, WHETHER ARISING OUT OF 
BREACH OF WARRANTY, CONTRACT, TORT (INCLUDING NEGLIGENCE), STRICT LIABILITY, OR 
OTHERWISE.

Copyright © 1997-1998 by QUALCOMM Incorporated. All rights reserved.

Eudora® is a registered trademark of QUALCOMM Incorporated.

PureVoice™, SmartRate™, Eudora Pro™, and Eudora Light™ are trademarks of QUALCOMM 
Incorporated.

QUALCOMM is a registered trademark and registered service mark of QUALCOMM Incorporated.

Microsoft, MS, and Windows are registered trademarks and Windows NT is a trademark of Microsoft 
Corporation in the U.S. and/or other countries.

Macintosh is a registered trademark of Apple Computer, Inc.

All other trademarks and service marks are the property of their respective owners.
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What Are PureVoice™ and SmartRate™?

PureVoice and SmartRate are high-quality, state-of-the-art voice-coding technologies developed by 
QUALCOMM Incorporated for use with wireless telephony applications, and in particular for use in digital 
cellular telephones.

Voice-coding technology compresses an incoming speech signal to transmit or store it in the most 
compact digital format possible while at the same time preserving the highest voice quality possible. The 
goal is to deliver a high compression factor; but voice quality tends to degrade as compression increases.
PureVoice technology delivers very high voice quality with a high compression factor, while SmartRate 
allows a higher compression factor without any significant degradation of the voice quality.



How Much Signal Compression is Offered?

When used on the Internet and with personal computers, PureVoice can reduce file size and transmission
time by more than a factor of ten compared to other common formats such as the .WAV format or the 
Macintosh SND format.

For example, a typical one-minute voice-mail message in a .WAV or SND file would take up about 1 MB 
of storage space and would take over 7 minutes to transmit using a 28.8 kbps modem. The same voice-
mail message coded with PureVoice would take less than 100 KB of space and would take less than 45 
seconds to transmit using the same modem speed. And using the same example, SmartRate technology 
would require storage of 60 KB for the message and a transmit time of 30 seconds. Here is a tabular 
representation of this example:

Coding Technology
(1-min voice message) Storage

Transmit Time
(28.8 kbps modem)

.WAV or SND file 1 MB > 7 minutes

PureVoice < 100 KB < 45 seconds

SmartRate 60 KB 30 seconds

Note that both PureVoice and SmartRate are variable-rate speech coders, so the actual amount of 
compression will be more or less than the compression factor quoted in the above example, depending 
on the input speech pattern. The numbers quoted above are conservative estimates for typical 
conversational speech.



Where Else Are PureVoice and SmartRate Used?

There are many voice-coding technologies available today, but PureVoice and SmartRate were designed 
specifically for cellular telephones and are part of the CDMA (Code Division Multiple Access) standard, 
which is the most recent standard for digital cellular telephony. CDMA was developed by QUALCOMM, 
and provides excellent clarity compared to older cellular telephone technologies.

PureVoice and SmartRate are widely deployed today in cellular telephones for many PCS systems in the 
United States and other CDMA wireless communications systems around the world.



How Do PureVoice and SmartRate Work?

Because radio frequency spectrum is expensive and high speech quality is important for cellular and 
wireless service providers, substantial research was invested in creating state-of-the-art speech 
compression technology. High compression factor and high voice quality are attained through a thorough 
understanding of human speech.

To give a more detailed explanation, a voice coder, or vocoder, takes digitized speech (PCM) at 
128 Kbits/second (kbps) as input and re-encodes it to a lower-rate digital bit-stream (packets), while 
keeping the perceived voice quality similar to, or as close as possible to, the original PCM signal. Both 
PureVoice and SmartRate achieve high voice quality at a high compression factor by adjusting the 
encoding process and bit rate to the incoming speech signal, thereby efficiently tuning the voice coder to 
a person’s speech pattern.

During pauses or silence, the bit rate is reduced sharply, unlike other speech coders, which encode 
everything — speech and silence — at the same rate. Therefore, both vocoders vary their bit rates (to a 
maximum of 13 kbps for PureVoice and 8 kbps for SmartRate) according to input speech pattern, 
exploiting natural pauses and silence very efficiently, leading to a very low average rate.



What Is the Voice Quality (MOS Score) Offered by This Technology?

Voice quality is difficult to quantify and is usually measured with a subjective metric called the Mean 
Opinion Score (MOS). In MOS testing, listeners at an independent, third-party judging organization judge 
the quality of vocoders by scoring them with numbers ranging from 1 (very poor) to 5 (excellent).

In a recent MOS test, PureVoice and SmartRate technologies were compared with two telephone-
standard vocoders: PCM (128 kbps) and ADPCM (32 kbps). PCM (Pulse Code Modulation) and ADPCM 
(Adaptive Delta Pulse Code Modulation) are used in regular telephones and deliver very high voice 
quality — technically known as “land-line quality” (PCM) and “toll quality” (ADPCM). In the test, PCM and
ADPCM received MOS scores of 4.21 and 3.68 respectively, while PureVoice (7.49 kbps average rate) 
and SmartRate (5.25 kbps average rate) received MOS scores of 4.12 and 4.01 respectively. Here is a 
tabular illustration of the results:

Vocoder MOS Score

PCM (land-line quality) 4.21

PureVoice 4.12

SmartRate 4.01

ADPCM (toll quality) 3.68

The results demonstrate that PureVoice and SmartRate technologies do offer a high voice quality, similar 
to or better than the quality found in regular telephone communications. PureVoice offers quality very 
close to land-line quality, and both PureVoice and SmartRate deliver better than toll quality.



Where Can I Get More Information?

For more information on QUALCOMM Incorporated, QUALCOMM’s CDMA advanced digital 
communication system, and QUALCOMM’s PureVoice™ and SmartRate™ voice encoding/decoding 
technologies, use your Web browser to visit the web sites <http://www.qualcomm.com> and 
<http://eudora.qualcomm.com>. Once there, search for the topic of your choice.

For additional product and licensing information on QUALCOMM’s PureVoice Player-Recorder, please 
submit message to <http://eudora.qualcomm.com/purevoice/bugs.html>. or send e-mail to 
<purevoice@qualcomm.com>.    You can even attach a voice message — we’ll listen!




